ACM笔记-动态规划

以poj 1837 为例

Description

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.

It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.

Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.

It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:

• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);

• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);

• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.

Output

The output contains the number M representing the number of possibilities to poise the balance.


Sample Input

2 4
-2 3
3 4 5 8

Sample Output

2

C++

//参考别人的做法,学习体会动态规划
//考察动态规划,opt[i][j]表示挂前i个砝码后重量因子为j的方法数
//15*20*25=7500   7500*2=15000
//动态规划关键就是找出子结构,和状态转移方程,边界条件
#include<iostream>
using namespace std;
int pos[21],goods[21];
int ans[25][15001]={0};
int main()
{
    int c,g;
    cin>>c>>g;
    for(int i=0;i<c;i++)
    {
        cin>>pos[i];
    }
    for(int i=0;i<g;i++)
    {
        cin>>goods[i];
    }
    ans[0][7500]=1;
    //初始状态,没有砝码的情况下,也平衡,故将其设置为1
    for(int i=1;i<=g;i++)
    {
        for(int j=1;j<=15000;j++)
        {
            if(ans[i-1][j]!=0)
            //表示前i-1个砝码挂上后存在平衡因子为j的平衡的方式
            {
                for(int k=0;k < c;k++)
                {
                    ans[i][j+goods[i-1]*pos[k]]+=ans[i-1][j];
                    //计算出挂上第i个砝码后,
                    //将其放在不同的位置产生的对应平衡因子的可能悬挂方式
                }
            }
        }
    }
    cout<<ans[g][7500]<<endl;
    return 0;
}


标签:none

知识共享许可协议
版权声明:本文版权属于作者 plumes,并受法律保护。
本作品采用知识共享「署名 - 非商业性使用 - 相同方式共享 3.0 未本地化版本」许可协议进行许可。