Organize Your Train part II
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5998 Accepted: 1730
Description
RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.
Figure 1: Layout of the exchange lines
A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from “a” to “z”. The cars of the same type are indistinguishable from each other, and each car’s direction doesn’t matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.
Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.
For example, if the arrival configuration is “abcd”, the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows (“+” indicates final concatenation position):
[3:1]
abc+d cba+d d+abc d+cba
[2:2]
ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba
[1:3]
a+bcd a+dcb bcd+a dcb+a
Excluding duplicates, 12 distinct configurations are possible.
Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.
Input
The entire input looks like the following.
the number of datasets = m
1st dataset
2nd dataset
…
m-th dataset
Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.
Output
For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.
Sample Input
4
aa
abba
abcd
abcde
Sample Output
1
6
12
18
大意是字符串被分割,子串颠倒然后再组合成新串,找出这个新串的可能性数量,直接用STL set除重会超时,直接插入字符串还是会超时,所以必须用字符串Hash,然后手工维护Hash值记录数组,限时1000MS,985MS过,汗!
这里有各种字符串Hash函数
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<set>
#include<cstdio>
using namespace std;
//set <unsigned int> res;
unsigned int res[100000]={0},cnt=0;
void insert(unsigned int hnum)
{
int i=0;
for(i=0;i<cnt;i++)
{
if(res[i]==hnum) break;
}
if(i==cnt)
{
res[cnt++]=hnum;
}
}
unsigned int Hash(string str)
{
unsigned int seed = 131; // 31 131 1313 13131 131313 etc..
unsigned int hash = 0;
int len=str.size();
for(int i=0;i<len;i++)
{
hash = hash * seed + (str[i]);
}
return (hash & 0x7FFFFFFF);
}
string sub(string str,int s,int l)
{
string nstr="";
for(int i=s;i<s+l;i++)
{
nstr+=str[i];
}
return nstr;
}
string rev(string str)
{
string rstr="";
int len=str.size();
for(int i=len-1;i>=0;i--)
{
rstr+=str[i];
}
return rstr;
}
int main()
{
int t;
string str,lstr,rlstr,rstr,rrstr;
char cstr[80],clstr[80],crstr[80];
//cin>>t;
scanf("%d",&t);
while(t--)
{
//res.clear();
memset(res,0,sizeof(res));
cnt=0;
//cin>>str;
scanf("%s",cstr);
str=cstr;
int len=str.size();
insert(Hash(str));
for(int i=1;i<=len-1;i++)
{
int flag1,flag2;
//tmpstr[0][0]=str.substr(0,i);
//tmpstr[0][1]=rev(tmpstr[0][0]);
lstr=sub(str,0,i);
rlstr=rev(lstr);
flag1=(Hash(lstr)==Hash(rlstr));
//tmpstr[1][0]=str.substr(i);
//tmpstr[1][1]=rev(tmpstr[1][0]);
rstr=sub(str,i,len-i);
rrstr=rev(rstr);
flag2=(Hash(rstr)==Hash(rrstr));
if(flag1 && flag2 )
{
insert(Hash(rstr+lstr));
}
else if(flag1 && !flag2)
{
insert(Hash(lstr+rrstr));
insert(Hash(rstr+lstr));
insert(Hash(rrstr+lstr));
}
else if(!flag1 && flag2)
{
insert(Hash(rlstr+rstr));
insert(Hash(rstr+lstr));
insert(Hash(rstr+rlstr));
}
else if(!flag1 && !flag2)
{
insert(Hash(lstr+rrstr));
insert(Hash(rlstr+rstr));
insert(Hash(rlstr+rrstr));
insert(Hash(rstr+lstr));
insert(Hash(rrstr+lstr));
insert(Hash(rstr+rlstr));
insert(Hash(rrstr+rlstr));
}
// for(int j=0;j<2;j++)
// {
// res.insert(tmpstr[j][0]+tmpstr[1-j][0]);
// res.insert(tmpstr[j][0]+tmpstr[1-j][1]);
// res.insert(tmpstr[j][1]+tmpstr[1-j][0]);
// res.insert(tmpstr[j][1]+tmpstr[1-j][1]);
// }
}
//cout<<res.size()<<endl;
//int ans=res.size();
printf("%d\n",cnt);
}
return 0;
}
版权声明:本文版权属于作者 plumes,并受法律保护。
本作品采用知识共享「署名 - 非商业性使用 - 相同方式共享 3.0 未本地化版本」许可协议进行许可。