DFS是最基本的算法之一了
以POJ 3009为例
Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7176 Accepted: 3003
Description
On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.
Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.
Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:
At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.
With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).
Fig. 3: The solution for Fig. D-1 and the final board configuration
Input
The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.
Each dataset is formatted as follows.
the width(=w) and the height(=h) of the board
First row of the board
…
h-th row of the board
The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.
Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.
0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
Output
For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.
Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1
题目大意是求从起点到终点的最少运动次数,每次运动直到遇到block才停止,若超出十次运动或者出界则结束,block每次被撞击后回消失。
//C++
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int maze[22][22]={0},start[2],end[2];
int flag,ans;int w,h;
int dir[4][2]={0,-1,1,0,0,1,-1,0};
int dfs(int ph,int pw,int step)
{
//cout<<"dfs:"<<ph<<" "<<pw<<" "<<step<<endl;
if(step>10) return 0;
for(int i=0;i<4;i++)
{
int tmph=ph,tmpw=pw,times=0;
while(maze[tmph+dir[i][0]][tmpw+dir[i][1]] == 0 || maze[tmph+dir[i][0]][tmpw+dir[i][1]] == 2)
{
tmph+=dir[i][0];
tmpw+=dir[i][1];
times++;
}/
// if(times==0)
// {
// cout<<tmph+dir[i][0]<<" "<<tmph+dir[i][1]<<endl;
// cout<<"hi\n";continue;}
if(maze[tmph+dir[i][0]][tmpw+dir[i][1]] == -1 ) {continue;}
//if(maze[tmph+dir[i][0]][tmpw+dir[i][1]] == 2) {continue;}
if(maze[tmph+dir[i][0]][tmpw+dir[i][1]] == 3)
{
flag=1;
ans=(ans<step?ans:step);
return 1;
}
if(maze[tmph+dir[i][0]][tmpw+dir[i][1]] == 1)
{
if(times==0)
{
//cout<<(tmph+dir[i][0])<<" "<<(tmpw+dir[i][1])<<endl;
continue;
}
maze[tmph+dir[i][0]][tmpw+dir[i][1]]=0;
dfs(tmph,tmpw,step+1);
maze[tmph+dir[i][0]][tmpw+dir[i][1]]=1;
}
}
return 0;
}
int main()
{
while(cin>>w>>h && (w!=0 || h!=0))
{
flag=0;ans=99;
memset(maze,0,sizeof(maze));
for(int i=0;i<=w+1;i++) {maze[0][i]=-1;maze[h+1][i]=-1;}
for(int i=0;i<=h+1;i++) {maze[i][0]=-1;maze[i][w+1]=-1;}
for(int i=1;i<=h;i++)
{
for(int j=1;j<=w;j++)
{
cin>>maze[i][j];
if(maze[i][j]==2) {start[0]=i;start[1]=j;}
if(maze[i][j]==3) {end[0]=i;end[1]=j;}
}
}
// for(int i=0;i<=h+1;i++)
// {
// for(int j=0;j<=w+1;j++)
// {
// cout<<maze[i][j]<<" ";
// }
// cout<<endl;
// }
//cout<<start[0]<<" "<<start[1]<<endl;
//cout<<end[0]<<" "<<end[1]<<endl;
dfs(start[0],start[1],1);
if(!flag) cout<<"-1\n";
else cout<<ans<<endl;
}
}
版权声明:本文版权属于作者 plumes,并受法律保护。
本作品采用知识共享「署名 - 非商业性使用 - 相同方式共享 3.0 未本地化版本」许可协议进行许可。