以POJ 1611 为例
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
//并查集,统计不相交集合的元素个数
#include <iostream>
using namespace std;
int n,m,k,fa[30010],num[30010],x,y;
void initSet()
{
for(int i = 0;i < n;++i)
fa[i] = i;
}
int Find(int x)
{
if(x == fa[x]) return x;
else return fa[x] = Find(fa[x]);//路径压缩
}
void Union(int x,int y)
{
x = Find(x);
y = Find(y);
if(x != y)
{
fa[y] = x;
num[x] += num[y];//把集合元素个数给加上去
}
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d%d",&n,&m) && n)
{
for(int i = 0;i < n;++i) num[i] = 1;//初始化统计每个集合都只有1个人
initSet();
while(m--)
{
scanf("%d",&k);k--;
scanf("%d",&x);
while(k--)
{
scanf("%d",&y);
Union(x,y);//只要是跟X同一个集合的都连上去
}
}
printf("%d/n",num[Find(0)]);//最后搜索0属于哪个集合,这个集合有多少人
}
return 0;
}
版权声明:本文版权属于作者 plumes,并受法律保护。
本作品采用知识共享「署名 - 非商业性使用 - 相同方式共享 3.0 未本地化版本」许可协议进行许可。